Access our e-learning programmes on the e-LfH Hub Hub Register / Log in >

Browsers

  • Recommended browsers

  • What do I need in order to access the e-learning resources?
    • You can access the e-learning resources from almost any computer or device that has an internet connection and a browser. However, for the best usability, we have tested the following browsers and are confident they will allow users to access all components of the platform successfully.

      Operating System Browser Publisher Version
      PC Firefox Mozilla Latest
      PC Chrome Google Latest
      PC Internet Explorer Microsoft 11
      PC Edge Microsoft Latest
      MAC Firefox Mozilla Latest
      MAC Chrome Google Latest
      MAC Safari Apple Latest
      Android 4.4+ Chrome Google Latest
      iOS8+ Safari Apple Latest

       

      To check that your computer is set up correctly for the learning materials, use the Technical Checker.

      Learn more about the policy on browsers and devices.

  • Can I use Internet Explorer 7, 8, 9 or 10 to access the e-LfH Hub?
    • Unfortunately, the e-LfH Hub does not work in older versions of Microsoft’s Internet Explorer web browser (IE7 through to IE10).

      e-LfH’s Browser Policy lists Internet Explorer 11 as the earliest Microsoft browser that is supported. This decision took effect on 1st January 2018 and brought e-LfH into line with the Electronic Staff Register (ESR) and Skills for Health.

      IE7 was released in 2006 and has been superseded by Internet Explorer 8, 9 10 and finally Internet Explorer 11, which is the latest release that is supported by e-LfH. In the intervening years since previous IE versions have been released, the internet and the technologies associated with it have evolved. The release of HTML5 and the rise of the iPad, for example, have changed the technological landscape and, as our users adopt these new technologies, so e-LfH has to respond to this demand.

      If you are using IE7, 8, 9 or 10 on a PC in a Trust, we suggest you approach your IT department and ask them to upgrade the browser. Alternatively, you could ask for your IT department to install a different browser altogether, such as Chrome or Firefox.

  • e-LfH browser policy